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What is Google Earth Modeling?

Google Earth is an online environment that performs best 

when models are created with this in mind. A well 
constructed model will load quickly and allow Google 

Earth to perform to its highest potential. 

All geo-referenced models go through an internal review 

process before being included in the “Best of the 3D 
Warehouse” layer in Google Earth. Following this guide is 

best way to get your models included in the layer!

Keys to Success

- Maintain accuracy in scale and location
- Focus on the important and identifying details

- Show small, intricate details through photo textures

- Keep a low polygon count

- Make it beautiful



Google Earth 
http://earth.google.com

3D interactive earth browser

Google SketchUp
http://sketchup.google.com

3D modeling tool

Adobe Photoshop
http://www.adobe.com

Advanced photo editing

Picasa
http://picasa.google.com

Photo editing and organization

3D Warehouse
http://sketchup.google.com/3dwarehouse

Online collection of 3D content

Useful Tools



Emporis
http://www.emporis.com

Building heights and details 

Google Search
http://www.google.com

Many searchable categories 

Wikipedia
http://www.wikipedia.org

The free encyclopedia

Skyscraperpage
http://www.skyscraperpage.com

Building heights, diagrams and forums

Archiplanet
http://www.archiplanet.org/

Building encyclopedia

Useful Resources



Terminology
Edge or Line

- Geometry that divides and borders faces.

Face or Polygon (Poly)
- A two-sided, flat surface bound by at least three lines.

Texture or Material

- Images or colors that are applied to faces.

Tiled Texture

- An images that repeats across a face.  “Tiling” creates textures.

Alpha Transparency

- The use of transparency in an image.

Low Poly

- Using a minimal number of edges and faces to limit file size and      

increase computer performance. 

File Size

- The amount of space your file uses on your computer. Models 

must be under 10MB to be uploaded to the 3D Warehouse.



Taking Pictures
- Take LOTS of pictures! You will need every 

façade, including alleys and courtyards. 

- Shoot around obstructions when you can, like 

trees, people, cars, etc.

- Include the context. Show the building in its 

surrounding area. 

- Include corner shots for use in matching a photo. 

Get detail 

shots.

Take multiple pictures 

of each façade.

Take multiple photos of 

long façades if they are 

too difficult to get in 

one shot. You can use a 

photo editor to stitch 

them together later. 

Take context 

pictures to help 

place the building.



Building a Model

Creating a successful model means creating 

one that accurately represents the building 

and also loads efficiently into Google Earth. 

Models with simple geometry and web ready 
textures will load quickly into an online 

environment such as Google Earth. 

- Getting started
- Simple modeling 

- Components

- Grounding your model

- Clean up



Open Google Earth.

- Find your building in Google Earth. Press the “R” key to align North to 

the top of the screen, giving a direct overhead (plan) view. 

- Be sure the Elevation Exaggeration is set to 1 in the Tools -> 

Options menu. 

- Be sure your terrain layer is check-marked. 

- Save the image without changing your position.  You will use this as 
your roof texture.  File -> Save -> Save Image

Open Google SketchUp

- Import terrain using Get Current View tool in SketchUp.

- Align the axes to match your building by using the Axes tool.

Incorrectly aligned axis Correctly aligned axis

Getting startedBuilding a Model



Curves are made of line segments 

in SketchUp. To simplify while 

drawing an arc or a circle, just type 

a number and “S” then hit Enter. 

Simple modeling

- Simplify the curves. Fewer 

faces means smaller file 

size and better 

performance.

- Many 3D building features 

can be portrayed in 2D. 

This complex looking shape is 

actually composed solely of flat 
faces with no depth.  This is a 

good technique for adding detail 

while keeping it simple.

Each Face has two sides.  Make 

sure the front (light) side of the 

face is outward. To view face 

orientation, View -> Face Style -> 
Monochrome

To reverse a face, Right click -> 

Reverse Faces

- Proper face orientation. 

Building a Model



Components

Use components for repetitive 

building features. SketchUp treats 

components as instanced entities, 

thus they load faster and help make 
files smaller.

- Select geometry

- Edit -> Make Component

Remember to keep these low 

poly too. 

This column only has three 

sides. The top and bottom 

faces have also been deleted.

Remember:  if you are adding 

a texture to a component or a 

group, you must double click 

to edit the object before you 
can apply the texture.  

Building a Model



- Make sure your model is sunk 

into the Google Earth terrain. 

Toggle the terrain on and off 

with the Toggle Terrain icon 
(See Advanced User Tips for 

more terrain tips). 

Grounding your model

Toggle the terrain on and 

off with the Toggle Terrain 

icon.  Then move your 

building vertically so that it 
sits in the ground. 

Building a Model



Clean up

- PURGE! Purge your model to 

cleanse it of unused textures 
and components. Window -> 

Model Info -> Statistics -> 

Purge Unused

Try to create models which 

are a hollow shell, without 

any internal lines or faces.

Z-Fighting is a sign of 

excess geometry and 

should be eliminated by 
deleting the excess faces. 

- While modeling, delete non-

visible faces and erase 

extra lines. 

- If you see flickering  faces 

in your model, you are 

experiencing Z-Fighting.

Building a Model



Photo Texturing

Photo texturing allows you to apply photographs 

onto your model. This will improve your model, 

make it realistic, and keep the polygon count low. 

One photograph may yield several unique textures, 
while others may be used only to aid in the creation 

of your model. 

- Applying a texture

- Positioning texture

- Matching the best photo

- Matching a photo

- Tracing a matched photo



Photo Texturing Applying a texture

- Using Picasa, crop your image as 

much as possible without losing 

any of the building. 

- In SketchUp, select  File -> 

Import, select your image, 

choose “Use as texture” and 
then open.

- Click on the face you wish to 

apply the texture to. Then 
stretch the texture across the 

face and click again. 



Photo Texturing Position texture

- Edit your texture by right clicking on the face 

and choose Texture -> Position. 

- There are four pins on the image.  Click on a 

pin once to pick it up then move it to a 

desired corner on the texture. Repeat for 

the remaining pins and corners. 

- Right click on the image and uncheck the 

“Fixed Pins” option. Then click and drag 
the pins to the corners of the model.

- Press Enter to finalize texture position. 

- Remember to place the roof texture in the 

same way.  Use the Google Earth terrain 
image you saved earlier and position it on 

the building.  It’s the easiest and most 

accurate way to show the roof.  

- For more photo texturing options and 

techniques, see Advanced User Tips. 



Photo Texturing Matching the best photo

- Find a picture of your building that shows a two 

point perspective (a corner shot). 

- Import your terrain from Google Earth and trace 

the footprint of your building.  

- Look at the picture you selected.  Align your 

axis in SketchUp so that the origin sits on the 

matching corner as shown in your picture.   

Horizon line

Blue Axis

Red Axis bar grip 

Green Axis bar grip

Vanishing point

Origin 

Green Axis

Red Axis

Matching a photo in SketchUp is the process of 

setting your model view to match the view of a 

picture that you took. 



Photo Texturing Matching a photo

- File -> Import, select your image, 

choose “as new matched photo”

and then click open…

- Move the origin to the matching 

corner on your image.

- Align the Green and Red bars with 

horizontal lines on the building in 

the image. 

- Move the mouse over the blue axis 

and click and drag to zoom. 
Match your traced footprint with 

the building in your photograph. 

- Click Done.

Don’t panic. 

Be sure to not align to 

the ground as it may 

not be horizontal.



Photo Texturing Tracing a matched photo

- Now you can trace the building outline.  

Remember only to pan and draw; orbiting 

will close the photo matching option. You 

can get back to the matched photo by 
clicking on the scene tab at the top of your 

model window. 

- After you have finished tracing your picture, 

click “Project textures from photo” or right 

click -> project photo on a specific face to 

texture your newly made model. 

Wireframe

Shaded

- If you match your model to a new photo, 

you must redefine the axes and origin.  



Geo-Modeling Checklist

Delete extra geometry inside and outside of your building.

Turn hidden geometry on, View -> Hidden Geometry, and check 

for excess hidden lines. 

Make sure your building is aligned with the base of the building

in your Google Earth snapshot. 

Toggle the terrain button and confirm that your building is 

planted in the ground. 

Export your model to Google Earth, File -> Export -> 3D Model 

and choose Google Earth 4 (.kmz).

Open the .kmz in Google Earth to check that it accurately 

represents the building. 

Make sure your SketchUp file is under 10MB for a successful 

upload to the 3D Warehouse. 

Try for a minimal number of faces (polygons), Window -> Model 

Info -> Statistics. Less then 500 is ideal for most buildings. 



Uploading Your Model

- In SketchUp, hide your lines and profiles for a 

cleaner screenshot. View -> Edge Style -> 

uncheck Display edges and Profiles. 

- Position your view on screen so that it is 

attractive. This will become your screenshot in 

the 3D Warehouse. 

- Click on the “Share Model” button.

- Set up a Google Account if you don’t already 

have one. 

- Fill in as many fields as you can with 

information about the building you modeled. 

Useful information like city name, architect, 
building materials, etc. help people find your 

building on the 3D Warehouse. 

- Make sure to check the “Google Earth 

Ready” checkbox. 

- Click Upload!



Best of the 3D Warehouse

After uploading, your geo-located model it is on its 

way to the “Best of the 3D Warehouse” layer in 

Google Earth. Here is how you find out if you made 

the cut.

- In Google Earth, turn on the Best of the 3D Warehouse 

layer and fly to your buildings location. 

- Your building should appear along with a little yellow 

house that shows you more information. 

- Check to see if your model has a blue Google Earth 

ribbon on the 3D Warehouse. 

Models will not appear in the layer immediately. They must 

go through a review process before being selected. Please 

allow up to 30 days for this process.



SketchUp Tips

SketchUp tips and tricks

-Ground effects

- Curves and projections

- Hide and unhide



SketchUp Tips Ground effects

- Adding color to your imported Google Earth terrain. 

http://sketchupdate.blogspot.com/2007/06/adding-

color-to-your-earth-snapshots.html

- Make sure to save an image from Google Earth 

at the same time you import your terrain into 

Google SketchUp. 

- Unlock your terrain, right click -> Unlock. 

- Double click to enter the group.

- Insert image you saved at the same time you 
imported your terrain.  Place it on the terrain. 

- Position the texture by dragging corners of the 
image to match the corners of the face. 

- Modeling terrain. 

- Sometimes the terrain in Google Earth does not 

match the actual terrain. When this happens you 
can model the terrain in Google SketchUp. 

Remember to keep it as low-poly as possible and 

to project the Google Earth ground texture onto 

your new terrain. 



- Toggle on the terrain.  

- Move the building so the 

correct part is sitting in the 
ground.  This probably means 

other parts are floating.

- Using the line tool, create  

connections with the bottom 

edges of the building and the 

terrain.  If you see “On Face,”
you can rest assured you are 

actually connected to the 

terrain.  

- When you are finished, paint 

the projected image of the 

Google Earth terrain on the 

new terrain.  

- Your building will now be 

placed in accurate terrain with 

an accurate texture.

Creating TerrainSketchUp Tips
- If your building seems to float above the 

terrain when you toggle it on, add terrain in 

SketchUp.  Keep in mind added terrain 

needs to use the fewest polygons as possible.  
. 1 2

3 4

5



SketchUp Tips Curves and projections

- Projecting textures 

- Right click on a texture and 

choose projected. This can be 

helpful for applying images to 

curved or angled faces. 

- Softening your curves

- If you draw something that needs 

smoothing, you can do so by 

selecting the Eraser tool then hold 

down the Ctrl key while erasing 
the edges. 

Remember when projecting 

textures you want the source 

texture to be at the normal to 
the curve. 



SketchUp Tips Hide and unhide

- Use hide and unhide to speed up 

computer performance.

- If you are experiencing slowdowns due 

to large file size, hide parts of the 

model you are not working on.  Your 

computer should run more smoothly.  
You can unhide them when you need to 

reference them again. 

- You can also hide unlocked terrain, right 

click –> Unlock.

- To view hidden geometry, View -> 

Hidden Geometry.



Photoshop Tips

A photo editor, like Adobe Photoshop, can be 

useful to edit photos before applying them to 

the model.    

- Crop out perspective

- Color correction

- Edit out obstructions 

- Advanced textures 

- Adding to textures

- Saving for web use



Photoshop Tips Crop out perspective

- Click on the Crop tool. After starting the crop, click 

the “Perspective” checkbox at the top of the 

screen. This will allow you to move corners of the 

crop box to match the perspective of the facade 
in your photo.

- Hit Enter to crop. Sometimes the crop tool leaves a 
bulge in your image caused by the camera lens. 

Use the Warp tool. 

Using the Warp tool: 

- “Ctrl + A” to select everything.

- “Ctrl + T” to start transforming. 

- Right click and select Warp. 

- Use the anchor points or just click and drag on the 

image to warp out curves. 

- Hit enter to end the transformation. 

Using Lens Correction filter:

- Start with un-cropped image.

- Select Filter -> Distort -> Lens Correction 

- Use “Remove Distortion” slider to correct the lens 

distortion. For typical point and shoot cameras, a 

value of 4 (four) will work well.



Photoshop Tips Color correction

Color correction can be difficult, but there are a 

few easy tools that can have remarkable results. 

Dodge and Burn:

- Use the Dodge tool to add brightness 

with a brush. 

- Use the Burn tool to subtract 

brightness with a brush. 

Quick Mask, “Q” Key:

The Quick Mask changes all actions to create 

areas which are masked (from selection).  

These show up in red.
- Press “Q” Key. 

- Press “Gradient tool” and make a gradient.

- Press “Q” Key again. 

- Now you have a selection that is a gradient 

that you can use to offset a gradient in 
your image. 

Image -> Adjustments -> Brightness/Contrast  

- Use sliders to adjust the brightness and 

contrast. 

Image -> Adjustments -> Hue/Saturation 

- Use sliders to adjust hue and saturation. 



Photoshop Tips Edit out obstructions

Use the selection and cloning tools to edit 

out obstructions.

- Use the Marquee tool to select an area: 

- Switch to the Move tool.

- Hold Alt and copy + drag your 
selection to cover obstructions with 

similar parts of the photo.

- Adding a feather to your selection 

can help blend any lines that you 

don’t want to appear in your texture. 

- Using the Healing Brush tool: 

- Pres the Alt key and use the 

target to select a source point.

- The tool then works to blend 

out imperfections. 

- Using the Clone Stamp tool: 

- Press the Alt key and use the 

curser to select a source point. 

- The tool then works like a 

brush that paints from your 
source point. 



Photoshop Tips Advanced textures

- Using alpha transparencies: 

- Unlock your background layer (double click on 

the layer) and erase the unwanted areas of the 

image with the Eraser tool or by selecting and 

deleting areas. 

- Save the image for web and select PNG-24. 

- Make sure to sample-paint your texture to the 

back side of face you put it on in SketchUp. 

- Making a tiled image: 

- Crop out a section of the image to use for tiling. 

- Use the Offset filter, Filter -> Other -> Offset, to 
offset your cropped image both horizontally and 

vertically. The Offset filter will move your image 

over the specified value and wrap the excess on 

the other side of the image. 

- Edit out the edges so that your image flows 

seamlessly in each direction. 



Photoshop Tips Adding to textures

- Adding a reflection:

- Place the desired reflection 

as a new layer in your file. 

- Lower the transparency until 

it looks believable.

- Use the eraser tool or other 

selection methods to take out 

any building features that 

would not reflect. 

- Adding a shadow:

- Use the Lasso tool or other 

selection methods to draw 

your desired shadow. 

- Right click and add a 

feather to your selection. 

- Use the brightness/contrast 

to create a shadow. 



Photoshop Tips Saving for web use

Saving for web is useful because it 

optimizes textures for faster use in web 

applications. 

- File -> Save for Web

- Choose JPEG (PNG 24 if you have a 
transparency). 

- There are two ways to optimize the file 
size:

- Decrease the quality slider

- Click on the “Image Size” tab

- Change the size of the image (this 

will only change the size of the file 

you save, it will not edit the file you 
have been working on).

- This shows you what the file size 
will be at the current settings.  


